PDF preview rendering "Please Wait..." message

Symptoms

Some PDF files containing fillable forms will not render a Preview in your digital workplace and instead are displayed with a “Please wait” message.


Error message on unsupported PDFs.

The PDF will also give this message if rendered in the browser or any reader that is NOT an Adobe product. Downloading the file and opening it in Acrobat will allow you to view and interact with the file normally.

Diagnosis

The PDF files that are not rendering and are giving the above message are special Adobe XFA Forms and were created in Adobe LiveCycle/Designer. These forms grant additional functionality but are not fully supported outside of the Acrobat Reader. This means that they need to be rendered in Acrobat and if they are not, they will show that “Please Wait…” message.

Actions

By design, the format of a file prevents previews from being generated. There are some workarounds available, though:

  • Convert the files to a flat fillable form (AcroForm) which will render and use those instead. This may result in some loss of functionality depending on how much of the XFA functionality you were using.
  • If there are forms that are especially important to have a preview for you could upload two versions, one converted as above. You can embed the preview of the converted version in an article or HTML widget and provide a link to download the file in the original format.
  • Finally, you could keep the old files and accept that they will not show a preview. Users will still be able to download and use the forms even if there is no preview.